Daily Dairy

How to fix Genymotion in linux with error `CXXABI_1.3.8′ not found.

Whenever I am trying to start genymotion(run command ./genymotion), the following error shown in my terminal.

./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/jagjeet/Downloads/genymotion/libQt5Core.so.5)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/jagjeet/Downloads/genymotion/libQt5WebKit.so.5)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/jagjeet/Downloads/genymotion/libicui18n.so.52)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/jagjeet/Downloads/genymotion/libicuuc.so.52)
./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/jagjeet/Downloads/genymotion/libQt5Qml.so.5)

Run the following commands to fix this:

$ LD_LIBRARY_PATH=/usr/local/lib64/:$LD_LIBRARY_PATH
$ export LD_LIBRARY_PATH
$ sudo apt-add-repository ppa:ubuntu-toolchain-r/test
$ sudo apt-get update
$ sudo apt-get install gcc-4.9 g++-4.9

Thank’s.

Advertisements

4 thoughts on “How to fix Genymotion in linux with error `CXXABI_1.3.8′ not found.”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s